Performance Degradation and Incomplete Model Loading

Incident Report for Catenda

Resolved

This incident has been resolved.
Posted Jan 13, 2026 - 08:00 UTC

Investigating

The system is experiencing significant performance drops during the model loading phase, resulting in models that do not fully render or appear incomplete in the viewport.
Posted Jan 13, 2026 - 01:00 UTC
This incident affected: Catenda Hub.